Please enable JavaScript to view the comments powered by Disqus.

Instalando Ruby 2.0.0 com RVM

No dia 24 de fevereiro foi lançada a versão 2.0.0 da linguagem Ruby. Uma das principais características da nova versão é o
Refinements. que visa resolver o problema de monkey-patching. Para um melhor detalhamento das novidades do Ruby 2.0.0
visite este link.
Antes de fazer a instalação, certifique-se de que o RVM esteja na última versão:

rvm get head  

Em seguida instale a biblioteca libyaml-dev tendo em vista que a syck e psych estão obsoletas no Ruby 2.0.0:

Para Debia/Ubuntu

apt-get install libyaml-dev  

para Fedora/CentOS/RHEL

yum install libyaml-devel  

para Mac com Homebrew

brew install libyaml  

Após a instalação das bibliotecas instale o Ruby 2.0.0:

rvm install ruby-2.0.0  

Altere a versão do Ruby:

rvm use 2.0.0  

É isso ai! Enjoy!

fonte

Discussions